Webdriver isn’t running and I am not getting any errors. I can’t tell what is wrong

I have not been able to figure out what is wrong, there are no errors and looks like it runs but the chrome window never opens and it just stays running on Spyder. I was trying to make a clickable button.

class MyTest(object): 
    def __init__(self):
        self.driver = webdriver.Chrome(os.getcwd()+"webdriverchromedriver.exe") 
    
    def login_process(self):
        self.driver.get("htttps://website.com/gr") 
        #successfully navigated to URL_1
        if self.driver.find_element_by_name("loginfmt"):
            elem = self.driver.find_element_by_name("loginfmt")
            elem.clear()
            elem.send_keys(["email"])
        #login button
            self.driver.find_element_by_id("idSIButton9").click()
               
    
    #password goes here
        if self.driver.find_element_by_id("i0118"):
            elem = self.driver.find_element_by_id("i0118")
            elem.clear()
            elem.send_keys(["password"])
            delay()
            self.driver.find_element_by_id("idSIButton9").click()
            
        def query(self):
            self.driver.get("https://website.com/d")
            delay()
            WebDriverWait(self.driver).until(EC.element_to_be_clickable((By.CLASS_NAME,"name element")))
            accept = WebDriverWait(self.driver, 11).until(EC.presence_of_element_located((By.CLASS_NAME, "name element")))
            actions = ActionChains(self.driver)
            actions.move_to_element(accept).click().perform()
    
            test = MyTest()
            test.login_process()
            test.query(test) 

Source: Python Questions

LEAVE A COMMENT