RequestsDependencyWarning: when running gsutil command

  gcloud, gsutil, python-3.x, python-requests

Im gettng the below error when i try to run this command on ubuntu 18
gsutil ls

/snap/google-cloud-sdk/161/lib/third_party/requests/init.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.

Tried to run gcloud components update but i got this error

(gcloud.components.update) You cannot perform this action because this Cloud SDK installation is managed by an external package manager.
Please consider using a separate installation of the Cloud SDK created through the default mechanism described at: https://cloud.google.com/sdk/

Am i missing anything ?

Source: Python-3x Questions

LEAVE A COMMENT