Error while trying to install flask-mysqldb in python 3.8 using pip install flask-mysqldb

  flask, flask-mysql, python, python-3.x

I’ve been trying to install flask-mysqldb in python 3.8 using pip install flask-mysqldb, but every time I try it gives me an error that says

The error is:

$ pip install flask-mysqldb
Requirement already satisfied: flask-mysqldb in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (0.2.0)
Requirement already satisfied: Flask>=0.10 in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from flask-mysqldb) (1.1.2)
Requirement already satisfied: mysqlclient in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from flask-mysqldb) (1.4.6)
Requirement already satisfied: Jinja2>=2.10.1 in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from Flask>=0.10->flask-mysqldb) (2.11.2)
Requirement already satisfied: Werkzeug>=0.15 in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from Flask>=0.10->flask-mysqldb) (1.0.1)
Requirement already satisfied: click>=5.1 in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from Flask>=0.10->flask-mysqldb) (7.1.2)
Requirement already satisfied: itsdangerous>=0.24 in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from Flask>=0.10->flask-mysqldb) (1.1.0)
Requirement already satisfied: MarkupSafe>=0.23 in c:usersroshanappdatalocalprogramspythonpython38-32libsite-packages (from Jinja2>=2.10.1->Flask>=0.10->flask-mysqldb) (1.1.1)

Source: Python-3x Questions

LEAVE A COMMENT