Sub-process /usr/bin/dpkg returned an error code (1). AGAIN

  apt, linux, pip, python-3.x, ubuntu

I realize this seems to be a very popular question but none of the fixes worked for me. I use ubuntu 18.04 and I’ve been unable to apt install anything for the good part of 6 months. It says the issue is coming from python3-pip which I am unable to use too. I tried purging it but I get a similar traceback.

dpkg: error processing package python3-pip (--remove):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting a removal
Errors were encountered while processing:
 python3-pip
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyone who has an idea how to fix this. It seems to have broken apt itself

Source: Python-3x Questions

LEAVE A COMMENT