ON DEVICE TRAINING: Cannot create interpreter: Op builtin_code out of range: 142. Are you using old TFLite binary with newer model?

  android, java, python, tensorflow, tensorflow-lite

Currently using

these Dependencies

from these snapshot repositories

To try and use on device training. As shown in this article by tf
https://www.tensorflow.org/lite/examples/on_device_training/overview.

When I try initialising the tflite interpreter I am getting

"java.lang.IllegalArgumentException: Internal error: Cannot create interpreter: Op builtin_code out of range: 142. Are you using old TFLite binary with newer model? Registration failed."

I have followed all the instructions provided to create the tflite using tf-nightly ‘2.7.0-dev20210919’ in python. I feel like the dependencies provided in Android might be the issue.

Please Help.

Source: Python Questions

LEAVE A COMMENT