Make pip install specific version of dependency package over installing latest

  pip, python

I have a requirements.txt with packages a and b.

a has a dependency called c==2.3.0.
b has the same dependency but c>=1.2
If c’s latest version available is 4.0, pip is installing that.
But, I need pip to install 2.3.0 How can I make pip do that?

Source: Python Questions

LEAVE A COMMENT