Error: No matching distribution found for spacy==2.1.7

  c++, pip, python, python-3.x, spacy

when i try to install spacy using pip install spacy==2.1.7 it produce an error i tried many things and it didn’t work i tried installing it locally and it produced a similar error so i thought about downloading a compiled package using pipwin and i didn’t find a binary package for 2.1.7 version i couldn’t but the errors here cause it’s pretty big and there is a maximum limitation here.
here’s the last few lines in the error:

https://files.pythonhosted.org/packages/f1/04/f25cdc3cb6d143ef397c23718026aff606c3e558cbd4939e9e4cb0a4b515/spacy-2.1.7.tar.gz#sha256=10b208898231153c67da4f2a34462eba201d0014b131de25565cb56b6582934c (from https://pypi.org/simple/spacy/) (requires-python:>=2.7,!=3.0.,!=3.1.,!=3.2.,!=3.3.). Command errored out with exit status 1: ‘C:UsersahmedAppDataLocalProgramsPythonPython38python.exe’ ‘C:UsersahmedAppDataLocalTemppip-standalone-pip-ltvs2b82_env_pip_.zippip’ install –ignore-installed –no-user –prefix ‘C:UsersahmedAppDataLocalTemppip-build-env-jrvkyxa6overlay’ –no-warn-script-location –no-binary :none: –only-binary :none: -i https://pypi.org/simple — setuptools ‘wheel>0.32.0.<0.33.0’ Cython ‘cymem>=2.0.2,<2.1.0’ ‘preshed>=2.0.1,<2.1.0’ ‘murmurhash>=0.28.0,<1.1.0’ ‘thinc>=7.0.8,<7.1.0’ Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement spacy==2.1.7 (from versions: 0.31, 0.32, 0.33, 0.40, 0.51, 0.52, 0.60, 0.61, 0.62, 0.63, 0.64, 0.65, 0.67, 0.68, 0.70, 0.80, 0.81, 0.82, 0.83, 0.84, 0.85, 0.86, 0.87, 0.88, 0.89, 0.90, 0.91, 0.92, 0.93, 0.94, 0.95, 0.97, 0.98, 0.99, 0.100.0, 0.100.1, 0.100.2, 0.100.3, 0.100.4, 0.100.5, 0.100.6, 0.100.7, 0.101.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.2.0, 1.3.0, 1.4.0, 1.5.0, 1.5.1, 1.6.0, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.5, 1.8.0, 1.8.1, 1.8.2, 1.9.0, 1.10.0, 1.10.1, 2.0.0, 2.0.1.dev0, 2.0.1, 2.0.2.dev0, 2.0.2, 2.0.3.dev0, 2.0.3, 2.0.4.dev0, 2.0.4, 2.0.5.dev0, 2.0.5, 2.0.6.dev0, 2.0.6, 2.0.7, 2.0.8, 2.0.9, 2.0.10.dev0, 2.0.10, 2.0.11.dev0, 2.0.11, 2.0.12.dev0, 2.0.12.dev1, 2.0.12, 2.0.13.dev0, 2.0.13.dev1, 2.0.13.dev2, 2.0.13.dev4, 2.0.13, 2.0.14.dev0, 2.0.14.dev1, 2.0.15, 2.0.16.dev0, 2.0.16, 2.0.17.dev0, 2.0.17.dev1, 2.0.17, 2.0.18.dev0, 2.0.18.dev1, 2.0.18, 2.1.0, 2.1.1.dev0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7.dev0, 2.1.7, 2.1.8, 2.1.9, 2.2.0.dev10, 2.2.0.dev11, 2.2.0.dev13, 2.2.0.dev15, 2.2.0.dev17, 2.2.0.dev18, 2.2.0.dev19, 2.2.0, 2.2.1, 2.2.2.dev0, 2.2.2.dev4, 2.2.2, 2.2.3.dev0, 2.2.3, 2.2.4, 2.3.0.dev1, 2.3.0, 2.3.1, 2.3.2, 2.3.3.dev0, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 3.0.0, 3.0.1.dev0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.1.1, 3.1.2, 3.1.3)
ERROR: No matching distribution found for spacy==2.1.7

Source: Python Questions

LEAVE A COMMENT