Sync Poetry with PIP

  pip, python, python-poetry

I have a virtual environment created with Poetry where I had installed some packages with pip (Airflow and their dependencies). When I execute pip list, I see all the packages installed.

I didn’t install Airflow with Poetry because is not supported: https://pypi.org/project/apache-airflow/

I want to update Poetry with all the installed packages with PIP, but I don’t know how to do this. When I execute poetry show I don’t see any of the packages installed.

There is a way of updating the poetry.lock with the current packages installed in the active environment? Thanks!

Source: Python Questions

LEAVE A COMMENT