ubuntu 16.04 python3 ImportError: Typelib file for namespace ‘Atk’, version ‘1.0’ not found

  gtk3, python, python-3.x, ubuntu-16.04
    >>> import gi
    >>> gi.require_version('Gtk', '3.0')
    >>> from gi.repository import Gtk
    Traceback (most recent call last):
      File "/usr/lib/python3/dist-packages/gi/importer.py", line 138, in load_module
        introspection_module = get_introspection_module(namespace)
      File "/usr/lib/python3/dist-packages/gi/module.py", line 275, in get_introspection_module
        module = IntrospectionModule(namespace, version)
      File "/usr/lib/python3/dist-packages/gi/module.py", line 122, in __init__
        repository.require(namespace, version)
    gi.RepositoryError: Typelib file for namespace 'Atk', version '1.0' not found
    
    During handling of the above exception, another exception occurred:
    
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
      File "/usr/lib/python3/dist-packages/gi/importer.py", line 140, in load_module
        raise ImportError(e)
    ImportError: Typelib file for namespace 'Atk', version '1.0' not found

Python 3.5.2 (default, Jan 26 2021, 13:30:48)
[GCC 5.4.0 20160609] on linux
Type "help", "copyright", "credits" or "license" for more information.

Source: Python-3x Questions

LEAVE A COMMENT