Category : alpine

I have a problem that started very recently, Docker Alpine python library is not installable anymore: apk update && apk upgrade && apk add python fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/main/x86_64/APKINDEX.tar.gz fetch https://dl-cdn.alpinelinux.org/alpine/v3.14/community/x86_64/APKINDEX.tar.gz v3.14.2-119-g9c4e1aa60c [https://dl-cdn.alpinelinux.org/alpine/v3.14/main] v3.14.2-120-g90167408c8 [https://dl-cdn.alpinelinux.org/alpine/v3.14/community] OK: 14943 distinct packages available (1/1) Upgrading alpine-keys (2.3-r1 -> 2.4-r0) 0% 2% # 5% ## 7% ### 10% #### 12% ##### ..

Read more

I have Dockerfile based on Alpine linux that builds lambda.zip file for AWS Lambda. Here’s Dockerfile: FROM alpine:3.12 # — Install OS packages: RUN apk add gcc RUN apk add –update –no-cache bash build-base cargo curl docker # gcc git g++ lftp libc-dev libffi-dev libsodium-dev libxslt-dev libzmq zeromq-dev make musl-dev ncftp nodejs npm openssh-client openssl ..

Read more

I’m brand new to Docker and have been trying to containerize my Django application. Whenever I run docker-compose up, I get: => ERROR [ 6/15] RUN pip3 install -r requirements.txt 0.2s —— > [ 6/15] RUN pip3 install -r requirements.txt: #10 0.207 /bin/sh: pip3: not found Dockerfile FROM python:3.9-alpine # Add scripts to PATH of ..

Read more

Please how should i install psycopg2-binary on my python image. I tried pip install psycopg2-binary==2.8.2 but i got this error ERROR: Could not find a version that satisfies the requirement psycopg2-binary==2.8.2 (from versions: 2.7.4, 2.7.5, 2.7.6, 2.7.6.1, 2.7.7, 2.8, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.8.5, 2.8.6, 2.9, 2.9.1) ERROR: No matching distribution found for psycopg2-binary==2.8.2 My ..

Read more

Well, i need an alpine chroot for run my Mongo DB Server, but i can’t because when i run the /usr/bin/python3 -m pip install -r etc/pip/compile-requirements.txt, it return’s to me this error: gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fomit-frame-pointer -g -fno-semantic-interposition -fomit-frame-pointer -g -fno-semantic-interposition -fomit-frame-pointer -g -fno-semantic-interposition -DTHREAD_STACK_SIZE=0x100000 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_SIZEOF_PID_T=4 -DPSUTIL_VERSION=580 -DPSUTIL_LINUX=1 ..

Read more

I am trying to install apache-airflow inside a docker image with alpine, the docker file is the following: FROM python:3.9.5-alpine3.13 WORKDIR /usr/app RUN pip install pipenv COPY Pipfile* ./ RUN apk add –no-cache libressl-dev musl-dev libffi-dev libressl-dev musl-dev libffi-dev gcc build-base RUN apk add gcc musl-dev libffi-dev openssl-dev python3-dev RUN apk update && apk add ..

Read more

I’m installing argon2 for Python with RUN apk add py3-argon2-cffi. This installs the Python argon2 package from Alpine (https://alpine.pkgs.org/3.14/alpine-community-x86_64/py3-argon2-cffi-20.1.0-r1.apk.html). When I try to import it with import argon2 I get ModuleNotFoundError: No module named ‘argon2′ I don’t want to install argon2 with pip because I don’t have gcc installed. gccwould tripple my container size and ..

Read more