Category : gsutil

I need to add data into the documents key within a json file with the structure below { "inputDocuments": { "gcsDocuments": { "documents": [ { "gcsUri": "gs://test/.PDF", "mimeType": "application/pdf" } ] } }, "documentOutputConfig": { "gcsOutputConfig": { "gcsUri": "gs://test" } }, "skipHumanReview": false The final output should be something like { "inputDocuments": { "gcsDocuments": { ..

Read more

I have a Cloud Build which gets triggered when a new commit is made to our Github repo, which is being mirrored in a Google Source Repo. Cloudbuild YAML file is given as below: – name: ubuntu id: Initialization args: [‘bash’, ‘-c’, "echo ‘$COMMIT_SHA’ > REVISION.txt"] – name: gcr.io/cloud-builders/gsutil id: Deployment args: [‘rsync’, ‘-r’, ‘-x’, ..

Read more

I’m running python code on Ubuntu with python3 test.py. However got following error: File "/opt/anaconda3/lib/python3.8/site-packages/geowombat/util/web.py", line 1679, in list_gcp proc = subprocess.run(gsutil_str.split(‘ ‘), File "/opt/anaconda3/lib/python3.8/subprocess.py", line 489, in run with Popen(*popenargs, **kwargs) as process: File "/opt/anaconda3/lib/python3.8/subprocess.py", line 854, in __init__ self._execute_child(args, executable, preexec_fn, close_fds, File "/opt/anaconda3/lib/python3.8/subprocess.py", line 1702, in _execute_child raise child_exception_type(errno_num, err_msg, err_filename) FileNotFoundError: ..

Read more

I am looking for help to troubleshoot my application written in Python3/Flask to be hosted on Google App Engine. The deployment succeeds, but there are issues with App Engine not able to access GCS. The code is as below: gs_util_command = "gsutil " gs_util_command = gs_util_command + " cp gs://"+ re.match(r"https.//storage.googleapis.com/(.*)",url1).group(1) gs_util_command = gs_util_command + ..

Read more

Im gettng the below error when i try to run this command on ubuntu 18 gsutil ls /snap/google-cloud-sdk/161/lib/third_party/requests/init.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown. Tried to run gcloud components update but i got this error (gcloud.components.update) You cannot perform this action because this Cloud SDK installation is managed by an ..

Read more