Category : installation

I am running a script related to ssm session in aws-cli. When I run it, I get a warning… /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/OpenSSL/crypto.py:12: CryptographyDeprecationWarning: Python 2 is no longer supported by the Python core team. Support for it is now deprecated in cryptography, and will be removed in the next release. However, if I run… python –version I ..

Read more

File /usr/lib/spark/python/lib/pyspark.zip/pyspark/cloudpickle/cloudpickle.py, line 562, in subimport import(name) ModuleNotFoundError: No module named jsonpickle I am getting the above error while running the program. I have tried using "pip install jsonpickle", "pip3 install jsonpickle" and also "pip3.6 install jsonpickle" Does jsonpickle not work with pyspark??? Source: Python-3x..

Read more

I try to install a python library and get the following error: ERROR: Command errored out with exit status 1: command: /usr/site/hpc/x86_64/generic/Anaconda3/2020.03/bin/python -c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"’/home/c703/c7031329/fairseq/setup.py’"’"’; __file__=’"’"’/home/c703/c7031329/fairseq/setup.py’"’"’;f=getattr(tokenize, ‘"’"’open’"’"’, open)(__file__);code=f.read().replace(‘"’"’rn’"’"’, ‘"’"’n’"’"’);f.close();exec(compile(code, __file__, ‘"’"’exec’"’"’))’ develop –no-deps –user –prefix= cwd: /home/c703/c7031329/fairseq/ Complete output (28 lines): running develop WARNING: The user site-packages directory is disabled. ..

Read more

My project structure looks like this: src/ ├—__init__.py └—domain/ ├—__init__.py ├—model/ | ├—__init__.py | └—model_mapper.py └—util/ ├—__init__.py └—utils.py test/ ├—__init__.py └—unit/ ├—__init__.py └—test_model_mapper.py And the settings.json is: { "python.pythonPath": "C:UsersasantAppDataLocalProgramsPythonPython37python.exe", "python.linting.flake8Enabled": true, "python.autoComplete.extraPaths": ["./src"], "python.terminal.executeInFileDir": true, "python.testing.pytestEnabled": true, "gitlens.currentLine.enabled": false, "gitlens.hovers.currentLine.over": "line", "gitlens.codeLens.enabled": false, "gitlens.hovers.enabled": false, "python.testing.pytestArgs": [ "test" ], "python.testing.unittestEnabled": false, "python.testing.nosetestsEnabled": false } ..

Read more

I was trying to install some new packages for a class this morning. Before that I could run Jupyter fine. Now, I’m getting messages like, "’C:Program’ is not recognized as an internal or external command, operable program or batch file." in Jupyter and "’C:UsersAceHerAnaconda2Scriptsactivate.bat’ is not recognized as an internal or external command, operable program ..

Read more

I try to install tikzplotlib in anaconda3 on Ubuntu 18.04. I tried both approaches described here. However, solving the environment fails. Here is the output: Collecting package metadata (current_repodata.json): done Solving environment: failed with initial frozen solve. Retrying with flexible solve. Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source. Collecting ..

Read more

i am unable to install autopy it is giving me this error: Collecting autopy Using cached autopy-4.0.0.tar.gz (20 kB) Building wheels for collected packages: autopy Building wheel for autopy (setup.py) … error ERROR: Command errored out with exit status 1: command: ‘C:UsershpAppDataLocalMicrosoftWindowsAppsPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0python.exe’ -u -c ‘import io, os, sys, setuptools, tokenize; sys.argv[0] = ‘"’"’C:UsershpAppDataLocalTemppip-install-ot6_lr7cautopy_f083340bbeb74ee1ba72431ea8181febsetup.py’"’"’; file=’"’"’C:UsershpAppDataLocalTemppip-install-ot6_lr7cautopy_f083340bbeb74ee1ba72431ea8181febsetup.py’"’"’;f = ..

Read more

I obtained the following error during an installation. ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. gitsome 0.8.4 requires click<7.0,>=5.1, but you have click 8.0.1 which is incompatible. I tried: pip install click<7.0,>=5.1 which led to ERROR: ..

Read more