Category : pipenv-install

I ran into what seems to be a dependency conflict when trying to run pipenv lock but can’t seem to figure out what is causing this: [pipenv.exceptions.ResolutionFailure]: Warning: Your dependencies could not be resolved. You likely have a mismatch in your sub-dependencies. You can use $ pipenv install –skip-lock to bypass this mechanism, then run ..

Read more

I am trying to install dependencies with pipenv install and receive modal letting me know that Python quit unexpectedly: I have uninstalled python, and installed from https://www.python.org/downloads/ (not using homebrew) Python version: 3.9.9 ; OS: Monterey 12.0.1 Pipfile: url = "https://pypi.python.org/simple" verify_ssl = true name = "pypi" [packages] Flask = "==2.0.2" flask-marshmallow = "==0.14.0" Flask-SQLAlchemy ..

Read more

So I know, it seems this question has been asked before, but I do believe I have a unique situation. I’m developing a Flask app (specifics below). I’ve created a virtual environment with pipenv. But no matter what I try, I keep getting this error: ModuleNotFoundError: No module named ‘passlib’ I’ve tried: pip install passlib ..

Read more

Im using python 3.7 Im new to python (my main dev experience comes from javascript). I understand there is a Pipfile who specify the packages Im using directly . Additionally, there is a Pipfile.lock which specifies exact versions of direct and indirect dependencies (like yarnpackage.lock in js ). requirements.txt looks like its doing the exact ..

Read more

I have a Pipenv file which looks something like this [[source]] url = "https://pypi.org/simple" verify_ssl = true name = "pypi" [packages] antlr4-python3-runtime = "4.8" numpy = "1.19.3" … However, when I create the environment by running pipenv install, the versions antlr4-python3-runtime==4.9.2 and numpy==1.21.2 are installed instead. If I modify the Pipfile in the following way: ..

Read more